有时候,新电脑上回碰到打开Eclipse时,弹出提示“Failed to load the JNI shared library jvm.dll”错误,这里给大家分享解决方案。

通常情况下,如果你是64位的系统,却安装了32位的JDK,就会导致上面的情况。

解决办法

1.卸载掉原来安装的32位的JDK,然后安装64位的JDK到电脑中。

2.重新修改path 和 classpath 两个环境变量。因为在64系统当中,32位软件回安装到program files (*86)文件夹,64位软件会安装到program files 文件夹,当你先前安装32JDK时,你设置的环境变量路径当中当然会包括“program files (*86)”,而这时JDK已经转移到“program files”中了,修改过来即可。

注意你两次安装的JDK版本号,不一定相同,因为安装时会根据你的版本号建立JDK文件夹,如果两次的版本号不同,在环境变量里也要修改。

现在,Eclipse应该可以正常使用了,快去练习Java程序吧!

实战——MyEclipse2014安装ADT插件

前段时间,本Eclipse部落里面分享了MyEclipse2014安装插件的几种方式(适用于Eclipse或MyEclipse其他版本),相信其中的方法方式也给了大家一些启示。Eclipse...

阅读全文

一条回应:“Eclipse启动时弹出“Failed to load the JNI shared library jvm.dll”错误的解决方法”

  1. 二先生说道:

    非常专业非常好,支持一下。

发表评论

电子邮件地址不会被公开。 必填项已用*标注